ATV Drag Racer Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter · #1 ·
Just finished a build on a new drag quad. I had it running initially, but noticed it had somewhat weak spark. When testing the quad, it was sluggish off the line. Did some tuning on it for quite some time to try and get it to come around with not much luck. After going over everything again, I noticed the pick up coil on the stator was cracked. Next I switched the stator and pick up coil with a new Ricky Stator unit. Then I went from having weak spark to no spark at all! I performed the ohm check on the stator and pick up coil and it is in spec. Next I switched the coil with another used one I had in the shop. Presto! Now I had fire again. Nice fat, blue spark. Better than what I had before. Here's where it went strange. I kicked it over about 4 or 5 times and the spark was fine. Then after kicking it over around that many more times again, the spark began to fade and now it has no spark..... AGAIN. Could I possibly be this darned unlucky to have two coils fail in such a short time? OR.... could there be something causing the coils to fail?
 

·
Premium Member
Joined
·
3,418 Posts
I will say this again...and from personal experience. Ricky Stator products are JUNK....ignition products anyways.

OEM stators are the only way to go, and stock, MSD, Nology are they ticket for coils....

Swap the stator with a known working OEM stator, check the pickup gap (.015 to .020), shake the flywheel in your hand and listen for broken up magnets inside....

Check all your grounds as well....
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #3 ·
QUOTE (dajogejr @ Jul 28 2008, 09:19 PM) index.php?act=findpost&pid=6840I will say this again...and from personal experience. Ricky Stator products are JUNK....ignition products anyways.

OEM stators are the only way to go, and stock, MSD, Nology are they ticket for coils....

Swap the stator with a known working OEM stator, check the pickup gap (.015 to .020), shake the flywheel in your hand and listen for broken up magnets inside....

Check all your grounds as well....

Yyeah, you're not the first person I've heard say that. Flywheel is good. Pick up coil gap was .020. I'll have to get my hands on a stock stator and another stock coil. Do you think the Ricky Stator unit fried the coil? Have you heard of them doing that?

I have a simplified stock wiring harness on this quad. The stator plugs directly to the CDI (no extension as found in stock harness). The other wires are connected as follows. Red with black stripe wire tied into black wire. Black wire connected to negative terminal on coil. Orange wire connected to positive terminal on coil. Black with white stripe connected to tether switch. Tether switch grounded to frame.

Thanks for the help.
 
1 - 3 of 3 Posts
Top