ATV Drag Racer Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
337 Posts
Discussion Starter · #1 ·
OK, this is a long shot but is it possible for the stock banshee cdi to malfunction by retarding the timing. My new dyno runs are 10 to 15% lower but the curves look the same as before. I have heard of the banshee cdi boxes just failing but then the bike doesn't run.

Any one have this happen to them?

Thanks,

Mailman

ps. We did piston modifications and case porting and lost a ton of hp. I put some new pistons in it and we will dyno again on Monday to see if that caused the problem. Nate McCoy thinks we screwed up the pistons so we are trying that first.
 

·
Registered
Joined
·
18 Posts
QUOTE (Mailman @ Feb 28 2009, 07:23 PM) index.php?act=findpost&pid=32634OK, this is a long shot but is it possible for the stock banshee cdi to malfunction by retarding the timing. My new dyno runs are 10 to 15% lower but the curves look the same as before. I have heard of the banshee cdi boxes just failing but then the bike doesn't run.

Any one have this happen to them?

Thanks,

Mailman

ps. We did piston modifications and case porting and lost a ton of hp. I put some new pistons in it and we will dyno again on Monday to see if that caused the problem. Nate McCoy thinks we screwed up the pistons so we are trying that first.had a cdi go bad before but the bike wouldnt start after and would back fire.try the pistons first ive seen the ports opened to much and hurt the power of the bike so maby that could be the problem.
 

·
Registered
Joined
·
337 Posts
Discussion Starter · #3 ·
Thanks fast guy. I will dyno Monday night and let you know. I have new pistons in it now. I hope I get my power back.


Mailman
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top