ATV Drag Racer Forums banner
1 - 20 of 32 Posts

·
Registered
Joined
·
489 Posts
Discussion Starter · #1 ·
my clutch is hard to pull. its adjusted right.

when you pull the clutch in only the pressure plate moves, the sling shot does not. is this normal.
 

·
Registered
Joined
·
489 Posts
Discussion Starter · #3 ·
stiff. it just feels real weird..

everything on the motor is adjusted right. tired like 4 different cables my clutch perch is on its last couple threads but that was like that last year to with a dd lock up.

but it just doesent feel right when you pull the clutch in
 

·
Premium Member
Joined
·
2,469 Posts
Well i know mine felt weird and would hardly move the lockout with the stiff springs in it.

I was wrong i dont know what i was thinking the whole lockout should move off the clutch plates.

I know it feels different than a DD lockout for sure you got alot more material there than a DD one.
 

·
Registered
Joined
·
489 Posts
Discussion Starter · #5 ·
QUOTE (BBIII @ Jul 9 2008, 07:34 PM) index.php?act=findpost&pid=4903Well i know mine felt weird and would hardly move the lockout with the stiff springs in it.

I was wrong i dont know what i was thinking the whole lockout should move off the clutch plates.

I know it feels different than a DD lockout for sure you got alot more material there than a DD one.

the preusse plate moves and you can see the clutch's move so Im guessing its taking pressure off, but I dont think the sling shot is moving any
 

·
Premium Member
Joined
·
2,469 Posts
Ok is the top cover not moving or the middle piece that replaces the pressure plate?

The Top cover wont move it is bolted to the hub.
 

·
Registered
Joined
·
489 Posts
Discussion Starter · #7 ·
QUOTE (BBIII @ Jul 9 2008, 06:43 PM) index.php?act=findpost&pid=4906Ok is the top cover not moving or the middle piece that replaces the pressure plate?

The Top cover wont move it is bolted to the hub.

I have a pressure plate on. the the hole sling shot unit itslef does not move...


are you tell me Im not supose to have a pressure plate on
 

·
Premium Member
Joined
·
2,469 Posts
Which one do you have the under cover one or light version?

For the stock cover or for the DD cover?
 

·
Premium Member
Joined
·
2,469 Posts
Ok i was thinking of the under cover one.

Does the instructions say to leave the pressure plate on there?

Mine is the under stock cover one.
 

·
Registered
Joined
·
489 Posts
Discussion Starter · #11 ·
lol I lost them so Im not real sure. but I think you are supose to leave the pressure plate on.

I have my cover off and went out and tested it the pressure plate moves and looks like it will release pressure but the complete sling shot unit does not move one bit.... by the why its looks it kind of looks like thats how its supose to work but not 100% sure
 

·
Premium Member
Joined
·
2,469 Posts
Ya sorry....lol

Well i am thinking it is correct, you could alway's pm Kevin and see what he says.
 

·
Registered
Joined
·
489 Posts
Discussion Starter · #14 ·
this might help me out.

this is just how it is installed.


this is with out the clutch being pulled


this is pulled in
 

·
Premium Member
Joined
·
3,418 Posts
Either your clutch isn't seated right, you have VERY thick fibers and steels, or..you need to either put washers under the spacers or have longer spacers made. Here's a pic of mine....and I already know it works.
First pic is with the back plate pushed up against the outer, with about .085 gap. Second, you can see the plate pushed against the pressure plate....it moves like butter by hand. You don't have any clearance, that's the problem.


 
1 - 20 of 32 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top